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Trusted devices in LogMeIn Central

Save time when logging in to your account by skipping password entry and/or two-factor authentication on devices you trust.

How do I designate a device as trusted?
When logging in to your account on any given device, you can select the following options, depending on your security settings: I trust this device. Keep me logged in. and/or Don't ask me for a code. I trust this device..
What is a trusted device?
On a device you designate as trusted, you are not required to enter a password and/or verification code to access your account.
How do I remove a trusted device?
On the LogMeIn.com website, go to Account settings > Trusted devices and select view devices. Review the list and remove devices as required.
What's the "trust period"?
By setting a trust period you are claiming how long you want to trust your devices. For each trusted device you will only be asked to verify your identity when logging in outside the trust period. Each login renews trust for a given device. To set your trust period, go to Account settings > Trust period and select change.
Tip: In LogMeIn Central, if Two-factor authentication is enabled under Users > Login Policy by the Master Account Holder, the Login Policy does not allow you to save devices.
Remember: You can only disable the trusted devices feature by enforcing Two-Factor Authentication (2FA).

Troubleshooting saving trusted devices

When logging in to your account, you select "I trust this device, keep me logged in" but your computer is not saved as a trusted device and you are prompted to input your login credentials the next time you try to log in from the same device.

Cause

In LogMeIn Central, if Two-factor authentication is enabled under Users > Login Policy by the Master Account Holder, the Login Policy does not allow you to save devices.

Action/Workaround

Contact your account's Master Account Holder and request that they change the Login process to Standard.

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